কার্মিকে চলবে লেক্সমার্ক এবং ডেল – এর কিছু প্রিন্টার

অনেক প্রিন্টারের ড্রাইভার রয়েছে যেগুলো libstdc++5 প্যাকেজটি ব্যবহার করে। কিন্তু কার্মিকে libstdc++6 প্যাকেজটি ডিফল্টভাবে দিয়ে দেয়ায় বেশ কিছু প্রিন্টারের ড্রাইভার হেলেনাতে ঠিক মত কাজ করতে পারে না। লেক্সমার্ক জি৬০০ ড্রাইভারটিও এই তালিকায় রয়েছে।

যেসব প্রিন্টার জি৬০০ ড্রাইভারে চলবে
লেক্সমার্কঃ ৫৭০০, এক্স১১০০, এক্স১১১০, এক্স১১৩০, এক্স১১৪০, এক্স১১৫০, এক্স১১৭০, এক্স১১৮৫, এক্স১১৯০, এক্স১১৯৫, এক্স১২৭০, জি২৫, জি৩৫, জি৫৫, জি৫১৩, জি৫১৫, জি৫১৭, জি৬০০, জি৬০৫, জি৬১২, জি৬১৫, জি৬৪০, জি৬৪৫, জি৭০৫, পি৩১৫০
ডেলঃ এ৯২০, ৭২০

১. প্রথমেই libstdc++5 প্যাকেজটি ডিপেন্ডেন্সিসহ দরকার হবে। তাই নিচের প্যাকেজ দুটি ডাউনলোড করব।

gcc-3.3-base_3.3.6-15_i386.deb
libstdc++5_3.3.6-15_i386.deb

২. এখন যথাক্রমে gcc-3.3-base_3.3.6-15_i386.deb এবং libstdc++5_3.3.6-15_i386.deb প্যাকেজ দুটি ইনস্টল করি।

৩. এখন alien প্যাকেজটি ইনস্টল করতে হবে।

sudo apt-get install alien

৪. এবার ডেস্কটপে লেক্সমার্ক (lexmark) শিরোনামে একটি ফোল্ডার তৈরী করে সেখানে ড্রাইভারটি ডাউনলোড করব।

$ cd ~/Desktop
$ mkdir lexmark
$ cd ~/Desktop/lexmark
$ wget http://www.downloaddelivery.com/srfilecache/CJLZ600LE-CUPS-1.0-1.TAR.gz

৫. ডাউনলোডকৃত tar.gz আর্কাইভটিকে extract করব।

$ tar -xvzf CJLZ600LE-CUPS-1.0-1.TAR.gz

৬. এখন একটি একটি করে নিচের কমান্ডগুলো টার্মিন্যালে রান করব।

$ tail -n +143 z600cups-1.0-1.gz.sh > install.tar.gz
$ tar -xvzf install.tar.gz
$ sudo alien -t z600cups-1.0-1.i386.rpm
$ sudo alien -t z600llpddk-2.0-1.i386.rpm
$ sudo tar xvzf z600llpddk-2.0.tgz -C /
$ sudo tar xvzf z600cups-1.0.tgz -C /
$ sudo ldconfig
$ cd /usr/share/cups/model
$ sudo gunzip Lexmark-Z600-lxz600cj-cups.ppd.gz
$ sudo /etc/init.d/cups restart

৭. এবার প্রিন্টার কনফিগারের করতে হবে। সেজন্য System → Administration → Printing → New → XXX (প্রিন্টারের নাম ও সিরিজ) → Make and Model – এর Change → Lexmark → z600 → Forward → Apply করব।

Advertisements
Comments
8 Responses to “কার্মিকে চলবে লেক্সমার্ক এবং ডেল – এর কিছু প্রিন্টার”
  1. শোয়েব বলেছেন:
    shoyeb@shoyeb-desktop:~$ sudo apt-get install alien
    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    alien is already the newest version.
    0 upgraded, 0 newly installed, 0 to remove and 270 not upgraded.
    shoyeb@shoyeb-desktop:~$ $ cd ~/Desktop
    $: command not found
    shoyeb@shoyeb-desktop:~$ $ cd ~/Desktop
    $: command not found
    shoyeb@shoyeb-desktop:~$ cd ~/Desktop
    shoyeb@shoyeb-desktop:~/Desktop$ 
    shoyeb@shoyeb-desktop:~/Desktop$  mkdir lexmark
    shoyeb@shoyeb-desktop:~/Desktop$ 
    shoyeb@shoyeb-desktop:~/Desktop$  cd ~/Desktop/lexmark
    shoyeb@shoyeb-desktop:~/Desktop/lexmark$ 
    shoyeb@shoyeb-desktop:~/Desktop/lexmark$ wget http://www.downloaddelivery.com/srfilecache/CJLZ600LE-CUPS-1.0-1.TAR.gz
    --2010-05-01 10:08:31--  http://www.downloaddelivery.com/srfilecache/CJLZ600LE-CUPS-1.0-1.TAR.gz
    Resolving www.downloaddelivery.com... 12.120.2.110
    Connecting to www.downloaddelivery.com|12.120.2.110|:80... connected.
    HTTP request sent, awaiting response... 200 OK
    Length: 4301167 (4.1M) [application/x-gzip]
    Saving to: `CJLZ600LE-CUPS-1.0-1.TAR.gz'
    
    100%[======================================>] 4,301,167   16.5K/s   in 4m 36s  
    
    2010-05-01 10:13:22 (15.2 KB/s) - `CJLZ600LE-CUPS-1.0-1.TAR.gz' saved [4301167/4301167]
    
    shoyeb@shoyeb-desktop:~/Desktop/lexmark$  tar -xvzf CJLZ600LE-CUPS-1.0-1.TAR.gz
    COPYING
    README
    z600cups-1.0-1.gz.sh
    shoyeb@shoyeb-desktop:~/Desktop/lexmark$ 
    shoyeb@shoyeb-desktop:~/Desktop/lexmark$ tail -n +143 z600cups-1.0-1.gz.sh > install.tar.gz
    shoyeb@shoyeb-desktop:~/Desktop/lexmark$ 
    shoyeb@shoyeb-desktop:~/Desktop/lexmark$  tar -xvzf install.tar.gz
    globals.tcl
    install
    lexinstall
    lexinstall.tcl
    license
    setup.tcl
    testpage
    usb.tcl
    xlexinstall
    xlexinstall.tcl
    z600cups-1.0-1.i386.rpm
    z600llpddk-2.0-1.i386.rpm
    shoyeb@shoyeb-desktop:~/Desktop/lexmark$ 
    shoyeb@shoyeb-desktop:~/Desktop/lexmark$ sudo alien -t z600cups-1.0-1.i386.rpm
    error: incorrect format: unknown tag
    Warning: Skipping conversion of scripts in package z600cups: postinst postrm preinst
    Warning: Use the --scripts parameter to include the scripts.
    z600cups-1.0.tgz generated
    shoyeb@shoyeb-desktop:~/Desktop/lexmark$ tar -xvzf install.tar.gz
    globals.tcl
    install
    lexinstall
    lexinstall.tcl
    license
    setup.tcl
    testpage
    usb.tcl
    xlexinstall
    xlexinstall.tcl
    z600cups-1.0-1.i386.rpm
    z600llpddk-2.0-1.i386.rpm
    shoyeb@shoyeb-desktop:~/Desktop/lexmark$  sudo alien -t z600cups-1.0-1.i386.rpm
    error: incorrect format: unknown tag
    Warning: Skipping conversion of scripts in package z600cups: postinst postrm preinst
    Warning: Use the --scripts parameter to include the scripts.
    z600cups-1.0.tgz generated
    shoyeb@shoyeb-desktop:~/Desktop/lexmark$ sudo alien -t z600llpddk-2.0-1.i386.rpmerror: incorrect format: unknown tag
    Warning: Skipping conversion of scripts in package z600llpddk: postinst postrm preinst prerm
    Warning: Use the --scripts parameter to include the scripts.
    z600llpddk-2.0.tgz generated
    shoyeb@shoyeb-desktop:~/Desktop/lexmark$  sudo tar xvzf z600llpddk-2.0.tgz -C /
    ./
    ./usr/
    ./usr/local/
    ./usr/local/z600llpddk/
    ./usr/local/z600llpddk/utility/
    ./usr/local/z600llpddk/utility/bnsi1.lut
    ./usr/local/z600llpddk/utility/lxbccln.out
    ./usr/local/z600llpddk/utility/lxbcalgn.out
    ./usr/local/z600llpddk/utility/bnsi2.lut
    ./usr/local/z600llpddk/utility/bnsi3.lut
    ./usr/include/
    ./usr/include/lexmark/
    ./usr/include/lexmark/cleaningdata.h
    ./usr/include/lexmark/alignmentdata.h
    ./usr/include/lexmark/cartridgeuserinterface.h
    ./usr/include/lexmark/cartridgemanager.h
    ./usr/include/lexmark/errorcommunicator.h
    ./usr/include/lexmark/printerdevice.h
    ./usr/include/lexmark/linuxinkjetprinter.h
    ./usr/include/lexmark/printjobmanager.h
    ./usr/include/lexmark/mediamanager.h
    ./usr/include/lexmark/clock.h
    ./usr/include/lexmark/portmonitor.h
    ./usr/lib/
    ./usr/lib/liblexprintjob.la
    ./usr/lib/liblexprintjob.so.0.0.0
    ./usr/lib/liblexz600core.so.0.0.0
    ./usr/lib/liblexprinter.a
    ./usr/lib/liblexprintjob.a
    ./usr/lib/liblexz600core.a
    ./usr/lib/liblexprinter.la
    ./usr/lib/liblexprinter.so.0.0.0
    ./usr/lib/liblexz600core.la
    shoyeb@shoyeb-desktop:~/Desktop/lexmark$  sudo tar xvzf z600cups-1.0.tgz -C /
    ./
    ./usr/
    ./usr/share/
    ./usr/share/cups/
    ./usr/share/cups/model/
    ./usr/share/cups/model/Lexmark-Z600-lxz600cj-cups.ppd.gz
    ./usr/lib/
    ./usr/lib/cups/
    ./usr/lib/cups/filter/
    ./usr/lib/cups/filter/rastertoz600
    ./usr/lib/cups/backend/
    ./usr/lib/cups/backend/z600
    shoyeb@shoyeb-desktop:~/Desktop/lexmark$  sudo ldconfig
    shoyeb@shoyeb-desktop:~/Desktop/lexmark$  cd /usr/share/cups/model
    shoyeb@shoyeb-desktop:/usr/share/cups/model$ 
    shoyeb@shoyeb-desktop:/usr/share/cups/model$  sudo gunzip Lexmark-Z600-lxz600cj-cups.ppd.gz
    gzip: Lexmark-Z600-lxz600cj-cups.ppd already exists; do you wish to overwrite (y or n)? y
    shoyeb@shoyeb-desktop:/usr/share/cups/model$ 
    shoyeb@shoyeb-desktop:/usr/share/cups/model$  sudo /etc/init.d/cups restart
     * Restarting Common Unix Printing System: cupsd                         [ OK ] 
    

    ভাই আমার ভুল কোথায় হয়েছে? প্রিন্ট করতে গেলে কিউতে এসে এরর দেখায়।

  2. শোয়েব বলেছেন:

    জ্বি। করেছিলাম। কাজ হয়নি।

    • Tareq বলেছেন:

      ১. tail -n +143 z600cups-1.0-1.gz.sh > install.tar.gz কমান্ডটি কি ঠিক মত রান করেছিলেন?
      ২. প্রিন্টার কি কনফিগার করেছেন? মানে ৭ নং ধাপটি কি অনুসরণ করেছেন?
      ৩. আপনি কি উবুন্টু ৯.১০ ব্যবহার করছেন? আপনার প্রিন্টারের মডেল নম্বর কত?

  3. shoyeb বলেছেন:

    sorry for english. i use ubuntu 9.10 printer lexmark z645 yeah i configure no 7 step. tail -n +143 z600cups-1.0-1.gz.sh > install.tar.gz- command work properly. thanks for your coordial advices. though i’m a novice in ubuntu you guyes play a mentors role for people like me.

  4. shoyeb বলেছেন:

    নতুন করে উবুন্টু সেট-আপ দিয়ে আপনার মেথড আবার অনুসরণ করলাম।এ বার কাজ হয়েছে। অনেক ধন্যবাদ।

  5. Ajom Mahmud বলেছেন:

    আপনার দেয়া প্যাকেজ গুলো ডাউনলোড হচ্ছে না। প্লিজ একটু দেখুন।

মন্তব্য করুন

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / পরিবর্তন )

Twitter picture

You are commenting using your Twitter account. Log Out / পরিবর্তন )

Facebook photo

You are commenting using your Facebook account. Log Out / পরিবর্তন )

Google+ photo

You are commenting using your Google+ account. Log Out / পরিবর্তন )

Connecting to %s

%d bloggers like this: